Hello community,

here is the log from the commit of package yast2-qt-pkg for openSUSE:Factory 
checked in at 2012-03-22 12:42:50
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/yast2-qt-pkg (Old)
 and      /work/SRC/openSUSE:Factory/.yast2-qt-pkg.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "yast2-qt-pkg", Maintainer is "tgoettlic...@suse.com"

Changes:
--------
--- /work/SRC/openSUSE:Factory/yast2-qt-pkg/yast2-qt-pkg.changes        
2012-03-17 13:23:45.000000000 +0100
+++ /work/SRC/openSUSE:Factory/.yast2-qt-pkg.new/yast2-qt-pkg.changes   
2012-03-22 12:42:55.000000000 +0100
@@ -1,0 +2,6 @@
+Wed Mar 21 14:30:14 CET 2012 - tgoettlic...@suse.de
+
+- Added shortcut to conflict dialog
+- Version: 2.21.21
+
+-------------------------------------------------------------------

Old:
----
  yast2-qt-pkg-2.21.20.tar.bz2

New:
----
  yast2-qt-pkg-2.21.21.tar.bz2

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ yast2-qt-pkg.spec ++++++
--- /var/tmp/diff_new_pack.j3g3Dg/_old  2012-03-22 12:42:56.000000000 +0100
+++ /var/tmp/diff_new_pack.j3g3Dg/_new  2012-03-22 12:42:56.000000000 +0100
@@ -18,14 +18,14 @@
 
 
 Name:           yast2-qt-pkg
-Version:        2.21.20
+Version:        2.21.21
 Release:        0
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
-Source0:        yast2-qt-pkg-2.21.20.tar.bz2
+Source0:        yast2-qt-pkg-2.21.21.tar.bz2
 Group:          System/YaST
 License:        GPL-2.0+
-BuildRequires:  docbook-xsl-stylesheets doxygen libdrm-devel libjpeg-devel 
libxcrypt-devel
+BuildRequires:  docbook-xsl-stylesheets doxygen libdrm-devel libjpeg-devel
 BuildRequires:  libqt4-devel libxslt perl-XML-Writer sgml-skel 
update-desktop-files
 
 Summary:        YaST2 - Graphical User Interface

++++++ yast2-qt-pkg-2.21.20.tar.bz2 -> yast2-qt-pkg-2.21.21.tar.bz2 ++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-qt-pkg-2.21.20/VERSION.cmake 
new/yast2-qt-pkg-2.21.21/VERSION.cmake
--- old/yast2-qt-pkg-2.21.20/VERSION.cmake      2012-03-16 11:02:56.000000000 
+0100
+++ new/yast2-qt-pkg-2.21.21/VERSION.cmake      2012-03-21 14:31:22.000000000 
+0100
@@ -1,3 +1,3 @@
 SET(VERSION_MAJOR "2")
 SET(VERSION_MINOR "21")
-SET(VERSION_PATCH "20")
+SET(VERSION_PATCH "21")
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-qt-pkg-2.21.20/package/yast2-qt-pkg.changes 
new/yast2-qt-pkg-2.21.21/package/yast2-qt-pkg.changes
--- old/yast2-qt-pkg-2.21.20/package/yast2-qt-pkg.changes       2012-03-16 
11:02:56.000000000 +0100
+++ new/yast2-qt-pkg-2.21.21/package/yast2-qt-pkg.changes       2012-03-21 
14:31:22.000000000 +0100
@@ -1,4 +1,10 @@
 -------------------------------------------------------------------
+Wed Mar 21 14:30:14 CET 2012 - tgoettlic...@suse.de
+
+- Added shortcut to conflict dialog
+- Version: 2.21.21
+
+-------------------------------------------------------------------
 Fri Mar 16 11:02:43 CET 2012 - tgoettlic...@suse.de
 
 - Fixed bnc#722325: untranslated rpm groups
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-qt-pkg-2.21.20/src/YQPkgConflictList.cc 
new/yast2-qt-pkg-2.21.21/src/YQPkgConflictList.cc
--- old/yast2-qt-pkg-2.21.20/src/YQPkgConflictList.cc   2012-03-16 
11:02:56.000000000 +0100
+++ new/yast2-qt-pkg-2.21.21/src/YQPkgConflictList.cc   2012-03-21 
14:31:22.000000000 +0100
@@ -305,9 +305,14 @@
     zypp::ProblemSolutionList solutions = problem()->solutions();
     zypp::ProblemSolutionList::iterator it = solutions.begin();
 
+    int n=0;
+
     while ( it != solutions.end() )
     {
-        QRadioButton * solutionButton = new QRadioButton( fromUTF8( ( *it 
)->description() ), this );
+        ++n;
+        QString shortcut = "" + QString( (n<10)?"&":"" ) +  QString::number(n) 
+ ": ";
+
+        QRadioButton * solutionButton = new QRadioButton( shortcut +  
fromUTF8( ( *it )->description() ), this );
         vbox->addWidget( solutionButton );
         _solutions[ solutionButton ] = *it;
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/yast2-qt-pkg-2.21.20/yast2-qt-pkg.spec.in 
new/yast2-qt-pkg-2.21.21/yast2-qt-pkg.spec.in
--- old/yast2-qt-pkg-2.21.20/yast2-qt-pkg.spec.in       2012-03-16 
11:02:56.000000000 +0100
+++ new/yast2-qt-pkg-2.21.21/yast2-qt-pkg.spec.in       2012-03-21 
14:31:22.000000000 +0100
@@ -4,7 +4,7 @@
 @HEADER@
 Group: System/YaST
 License:        GPL-2.0+
-BuildRequires: docbook-xsl-stylesheets doxygen libdrm-devel libjpeg-devel 
libxcrypt-devel
+BuildRequires: docbook-xsl-stylesheets doxygen libdrm-devel libjpeg-devel
 BuildRequires:  libxslt perl-XML-Writer libqt4-devel sgml-skel 
update-desktop-files
 
 Summary:       YaST2 - Graphical User Interface

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org

Reply via email to