>
> Hello,
>
> this defect was found by cppcheck, however cppcheck still complains.
> so, we did not make it happy yet.
>
> I think, the best would be split this function into 2 separate functions
> (with either null argument) or leave it like that.
Unrelated to an actual fix, IMHO we should at least break up
out = alloc_buf_gc (maxoutput ? maxoutput :
((size * 2) + (size / (space_break_flags &
FHE_SPACE_BREAK_MASK)) * (int) strlen (separator) + 2),
gc);
and create a variable with a semantic variable for the result of "((size * 2)
+ (size / (space_break_flags & FHE_SPACE_BREAK_MASK)) * (int) strlen
(separator) + 2)”
Honestly the calculation looks very arcane and I would better understand it, if
i knew what it means :-)
Jens
------------------------------------------------------------------------------
_______________________________________________
Openvpn-devel mailing list
Openvpn-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/openvpn-devel