Attention is currently required from: cron2, ordex, plaisthos.

its_Giaan has posted comments on this change. ( 
http://gerrit.openvpn.net/c/openvpn/+/764?usp=email )

Change subject: Add support for simultaneous use of UDP and TCP sockets
......................................................................


Patch Set 19:

(10 comments)

File doc/man-sections/link-options.rst:

http://gerrit.openvpn.net/c/openvpn/+/764/comment/bb017af8_98251213 :
PS18, Line 122:
> I think we also should mention the default values, something like […]
Done, see options_postprocess_mutate_le(), now in a case like:

local * 1000 tcp
remote 1.2.3.4 1194 udp

Only the remote proto will be used


File src/openvpn/mudp.c:

http://gerrit.openvpn.net/c/openvpn/+/764/comment/a19e31fc_278f6bab :
PS18, Line 335:     const unsigned int status = m->multi_io->udp_flags;
> I do wonder why a separate `udp_flags` field for UDP has been introduced. […]
As said in a comment above, the multi_io has no event_set_status member and 
since UDP require that I decided to call it udp_flags since it is UDP specific.


File src/openvpn/multi.h:

http://gerrit.openvpn.net/c/openvpn/+/764/comment/9b01bf4b_df045866 :
PS19, Line 256:  * on the transport protocols:
> The wording is a bit odd... […]
Done


File src/openvpn/multi_io.c:

http://gerrit.openvpn.net/c/openvpn/+/764/comment/8d2cfb2d_b69e0502 :
PS19, Line 145:                    
!proto_is_dgram(mi->context.c2.link_sockets[0]->info.proto) ? &mi->tcp_rwflags 
: NULL);
> I like that this is being moved to a dedicated function :-) - I would style 
> it differently, though,  […]
TCP ev_arg are usually of type 'mi' while UDP are of type 'link_sockets'.


http://gerrit.openvpn.net/c/openvpn/+/764/comment/37cd169e_1703017b :
PS19, Line 491:                         }
> since this is the same `if (mi)` now, it could go outside one level, avoid 
> code duplication... […]
Done


File src/openvpn/openvpn.h:

http://gerrit.openvpn.net/c/openvpn/+/764/comment/1ddc2f85_7dceb3e5 :
PS19, Line 219:  * tunnel_point_to_point(), \c tunnel_server() \c
> an `and` is missing before `tunnel_server()`  (since it's only these 2 
> functions now)
Done


File src/openvpn/options.c:

http://gerrit.openvpn.net/c/openvpn/+/764/comment/1e2cfd64_b9b578a8 :
PS18, Line 3351:     if (!le->proto)
> it says `acknowledged` but we still have no comment for `proto`? ;-)
I've also added a check to avoid proto bindings on client side


http://gerrit.openvpn.net/c/openvpn/+/764/comment/8fe0a241_34255d82 :
PS18, Line 3839:
> so what does "Acknowledged" mean, here?  "Will be handled in a future patch"?
Done


File src/openvpn/options.c:

http://gerrit.openvpn.net/c/openvpn/+/764/comment/bc60012a_289c4f91 :
PS19, Line 1747:             o->local_list->array[i]->port);
> I think this should show `proto` now as well, otherwise the log is a bit hard 
> to read if trying to u […]
Done


File src/openvpn/socket.c:

http://gerrit.openvpn.net/c/openvpn/+/764/comment/80bb9647_fc94b5d2 :
PS18, Line 1914:     ASSERT(c->c2.link_sockets[sock_index]);
> maybe gerrit is playing tricks on me, but the `ASSERT()` seems to be still 
> here
Done



--
To view, visit http://gerrit.openvpn.net/c/openvpn/+/764?usp=email
To unsubscribe, or for help writing mail filters, visit 
http://gerrit.openvpn.net/settings

Gerrit-Project: openvpn
Gerrit-Branch: master
Gerrit-Change-Id: I31bbf87e4e568021445c7512ecefadfd4a69b363
Gerrit-Change-Number: 764
Gerrit-PatchSet: 19
Gerrit-Owner: its_Giaan <gianma...@mandelbit.com>
Gerrit-Reviewer: cron2 <g...@greenie.muc.de>
Gerrit-Reviewer: flichtenheld <fr...@lichtenheld.com>
Gerrit-Reviewer: plaisthos <arne-open...@rfc2549.org>
Gerrit-CC: openvpn-devel <openvpn-devel@lists.sourceforge.net>
Gerrit-CC: ordex <a...@unstable.cc>
Gerrit-Attention: plaisthos <arne-open...@rfc2549.org>
Gerrit-Attention: cron2 <g...@greenie.muc.de>
Gerrit-Attention: ordex <a...@unstable.cc>
Gerrit-Comment-Date: Wed, 05 Mar 2025 16:59:21 +0000
Gerrit-HasComments: Yes
Gerrit-Has-Labels: No
Comment-In-Reply-To: cron2 <g...@greenie.muc.de>
Comment-In-Reply-To: its_Giaan <gianma...@mandelbit.com>
Gerrit-MessageType: comment
_______________________________________________
Openvpn-devel mailing list
Openvpn-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/openvpn-devel

Reply via email to