Attention is currently required from: flichtenheld. plaisthos has posted comments on this change by plaisthos. ( http://gerrit.openvpn.net/c/openvpn/+/1727?usp=email )
Change subject: Add lookup of multi session by session id ...................................................................... Patch Set 3: (10 comments) File doc/man-sections/advanced-options.rst: http://gerrit.openvpn.net/c/openvpn/+/1727/comment/d82a4f50_1f10f5ae?usp=email : PS3, Line 32: address table to ``v``. And if specified the session id hash table to > "If specified set the size of the session id hash table to" Done http://gerrit.openvpn.net/c/openvpn/+/1727/comment/2336da00_72054d17?usp=email : PS3, Line 33: ``s``. Otherwise ``s`` be set to the same value as ``r``. > "will be" Done File src/openvpn/mudp.c: http://gerrit.openvpn.net/c/openvpn/+/1727/comment/fa7d8345_5eed2d6d?usp=email : PS3, Line 383: if (m->top.c2.buf.len < 9) > Why hardcode 9 instead of "sizeof(struct session_id) + 1" ? Replaced with (int)SID_SIZE + 1. File src/openvpn/multi.h: http://gerrit.openvpn.net/c/openvpn/+/1727/comment/10ae17ac_5a2d983b?usp=email : PS3, Line 138: * id here is non-null and the hash map's key pointer uses is pointing > Not sure what "uses" is supposed to mean here? Done http://gerrit.openvpn.net/c/openvpn/+/1727/comment/0e7fda90_da142616?usp=email : PS3, Line 139: * here */ > What is "here"? Sounds like it points to this part of the struct, but it > actually points to the begi […] Our hash map is a bit weird in the way that it does not store the keys but actually only pointers to the keys and this field is the key while the whole struct is the value. I adjusted the comment to reflect this pbacker http://gerrit.openvpn.net/c/openvpn/+/1727/comment/cddba2a0_341624a4?usp=email : PS3, Line 178: session id. We do not care collisions here > "care about" Done File src/openvpn/multi.c: http://gerrit.openvpn.net/c/openvpn/+/1727/comment/03567279_523e52ce?usp=email : PS3, Line 441: if (mi->context.c2.tls_multi && true) > "&& true" ? sorry. Debug leftover. Removed File src/openvpn/sid_hash.h: http://gerrit.openvpn.net/c/openvpn/+/1727/comment/7f6f7a89_099de1be?usp=email : PS3, Line 35: /* This only be called if the multi instance is not already present > "This should" or "This must"? Done http://gerrit.openvpn.net/c/openvpn/+/1727/comment/ba72e6af_e5b31bda?usp=email : PS3, Line 52: struct hash_element *he = hash_lookup_fast(m->sid_hash, bucket, sid, hv); > Could reduce code duplication slightly by using multi_hash_sid_lookup here. Good catch. Thanks. File tests/unit_tests/openvpn/test_misc.c: http://gerrit.openvpn.net/c/openvpn/+/1727/comment/b66473fc_30efedcc?usp=email : PS3, Line 143: get_random(void) > ``` […] Done -- To view, visit http://gerrit.openvpn.net/c/openvpn/+/1727?usp=email To unsubscribe, or for help writing mail filters, visit http://gerrit.openvpn.net/settings?usp=email Gerrit-MessageType: comment Gerrit-Project: openvpn Gerrit-Branch: master Gerrit-Change-Id: Idb59ecd119331b198792ad1379bec8600211651b Gerrit-Change-Number: 1727 Gerrit-PatchSet: 3 Gerrit-Owner: plaisthos <[email protected]> Gerrit-Reviewer: flichtenheld <[email protected]> Gerrit-CC: openvpn-devel <[email protected]> Gerrit-Attention: flichtenheld <[email protected]> Gerrit-Comment-Date: Tue, 14 Jul 2026 13:01:00 +0000 Gerrit-HasComments: Yes Gerrit-Has-Labels: No Comment-In-Reply-To: flichtenheld <[email protected]>
_______________________________________________ Openvpn-devel mailing list [email protected] https://lists.sourceforge.net/lists/listinfo/openvpn-devel
