Hello list,

I have a machine running Ubuntu Hardy which I have been using with the Orca screen reader. I recently purchased Voxin for the IBM tts voice and the installer successfully installed the voice for use with gnome-speech.


But I am interested in trying out Emacspeak and so ran the installer again and chose to install Emacspeak support.

The installer installed Emacspeak and it's dependancies but then produced the following error output when trying to compile the tts driver.

libtool --mode=compile g++ -I /usr/include/tcl8.4/ -g -O2 -fPIC -DPIC -Wall -c langswitch.cpp g++ -I /usr/include/tcl8.4/ -g -O2 -fPIC -DPIC -Wall -c langswitch.cpp -fPIC -DPIC -o .libs/langswitch.o langswitch.cpp: In function ‘ECILanguageDialect initLanguage(Tcl_Interp*, ECILanguageDialect*, int)’: langswitch.cpp:79: warning: deprecated conversion from string constant to ‘char*’ langswitch.cpp:84: warning: deprecated conversion from string constant to ‘char*’
langswitch.cpp: In function ‘const char* getAnnotation(Tcl_Interp*, int*)’:
langswitch.cpp:172: error: invalid conversion from ‘const char*’ to ‘char*’
make: *** [langswitch.lo] Error 1

I am stuck as to what to do next. Any help would be gratefully appreciated.

Paul
_______________________________________________
Oralux mailing list
Oralux@lists.freearchive.org
http://lists.freearchive.org/mailman/listinfo/oralux

Reply via email to