No, I considered looping because we are working on a complex network, and tested it removing any possible looping on it. However, after some testing, we came to the conclusion it was being caused some kind of hardware limitations, since we were working with devices not so powerful.

We replaced the devices for others a bit more powerful, and it worked for a while, until we took that one over the limit too building something a bit more complex, with a similar problem and still no loops, supporting our theory of being some hardware limitation.


I am still working on finding out exactly what is going wrong, so we can take it into account for future developing, but haven't found anything specific yet.


El 08/08/17 a las 23:58, Ben Pfaff escribi├│:
On Mon, Jul 24, 2017 at 01:04:34PM +0200, Pablo Pousada wrote:
I've been encountering an error on the testbed I'm building, where having
multiple ports added to a ovs bridge blocks all outwards communication.

Example: Having the following setup, i have connectivity through the eth0.3
port:

root@LEDE:~# ovs-vsctl show
41ae4f8f-55db-4cd0-8dd1-3e7b001d8f54
     Bridge "br0"
         Controller "tcp:192.168.1.151"
         Port "br0"
             Interface "br0"
                 type: internal
         Port "eth0.3"
             Interface "eth0.3"

Whenever I add another port to that bridge, inward packages are received,
but outward packages are never sent. The problem persists with or without
controller.

┬┐Does anyone have any info on where the problem might be?

I'm using Open vSwitch version 2.5.0 over LEDE.
This sounds like the second question here:
http://docs.openvswitch.org/en/latest/faq/issues/

_______________________________________________
discuss mailing list
disc...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-discuss

Reply via email to