Your config for g3/0/1 is missing the most important bit.

I have it set up on a 2960X but the same config should work on a 3750.

You must configure some sort of port authorisation by adding:-

Interface g3/0/1
 authentication host-mode multi-host
 authentication order mab dot1x
 authentication priority mab dot1x
 authentication port-control auto
 authentication periodic
 authentication timer reauthenticate 60
 mab
 dot1x pae authenticator
 dot1x timeout quiet-period 2
 dot1x timeout tx-period 3
 spanning-tree portfast
!

And add a RADIUS server:-
!
aaa group server radius packetfence
 server name packetfence
!
aaa authentication login default group tacacsgroup local
aaa authentication dot1x default group packetfence
aaa authorization config-commands
aaa authorization network default group packetfence
aaa accounting network default start-stop group packetfence
!
radius server packetfence
 address ipv4 <IP Address of your PF server MGMT interface> auth-port 1812 
acct-port 1813
 timeout 2
 key <YOUR RADIUS SECRET>
!!
!
! If you want to do RADIUS accounting on the port then
!
aaa server radius dynamic-author
 client <IP address of your PACKETFENCE MGMT interface>
 server-key <YOUR RADIUS SECRET>
 port 3799
!

HTH

Andrew



-----------------------------
     Falmouth University
-----------------------------

-----Original Message-----
From: Jeroen van Leur [mailto:jeroen.vanl...@os3.nl]
Sent: 20 March 2017 09:11
To: packetfence-users@lists.sourceforge.net
Subject: [PacketFence-users] After registration remain in registration subnet

Hey,

I am trying to set up a simple Packetfence VLAN enforcement configuration. I’ve 
followed the Out-of-band quick guide on the website and I have ended up with an 
issue.
Whenever I connect to my Cisco 3750G switch it puts me in the Registration 
VLAN(10.1.2.x) even though I registered the first time and in the interface the 
device is set to registered.
However, what I expected is the retrieval of an IP address in the ‘default’ 
range (VLAN 400 as I set it up with the range 10.1.4.x)
Here is what I did, I configured in Packetfence VLAN 400 as the default and I 
added the following configuration to my Cisco 3750G switch.
The following is not everything I have configured, I have left out the other 
VLAN configuration.

ip dhcp pool default-pool
   network 10.1.4.0 255.255.255.0
   default-router 10.1.4.1
   dns-server 10.1.4.1

interface GigabitEthernet3/0/1
 switchport mode access vlan 200

interface GigabitEthernet3/0/2
 description uplink
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,200,300,400
 switchport mode trunk

interface Vlan400
 description default
 ip address 10.1.4.1 255.255.255.0

Could someone please help me with this issue.

Thanks a lot for your attention.

Best Regards,

Jeroen van Leur
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
PacketFence-users mailing list
PacketFence-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/packetfence-users
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
PacketFence-users mailing list
PacketFence-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/packetfence-users

Reply via email to