Hi,

I ran my usual update this morning and have suddenly started getting problems with i586 packages, which is weird as I'm running x86_64.


[richard@andromeda-ascendant ~]$ rpm -qa | grep vlc-codecs
vlc-codecs-2.2.4-12.3.x86_64
[richard@andromeda-ascendant ~]$ zypper lr --details
# | Alias            | Name             | Enabled | GPG Check | Refresh | 
Priority | Type   | URI                                                         
  | Service
--+------------------+------------------+---------+-----------+---------+----------+--------+---------------------------------------------------------------+--------
1 | packman          | packman          | Yes     | (r ) Yes  | Yes     |   95  
   | rpm-md | http://packman.jacobs-university.de/suse/openSUSE_Tumbleweed/ |
2 | repo-debug       | repo-debug       | Yes     | (r ) Yes  | Yes     |   99  
   | yast2  | http://download.opensuse.org/tumbleweed/repo/debug            |
3 | repo-non-oss     | repo-non-oss     | Yes     | (r ) Yes  | Yes     |   99  
   | yast2  | http://download.opensuse.org/tumbleweed/repo/non-oss          |
4 | repo-oss         | repo-oss         | Yes     | (r ) Yes  | Yes     |   99  
   | yast2  | http://download.opensuse.org/tumbleweed/repo/oss              |
5 | repo-src-non-oss | repo-src-non-oss | Yes     | (r ) Yes  | Yes     |   99  
   | yast2  | http://download.opensuse.org/tumbleweed/repo/src-non-oss      |
6 | repo-src-oss     | repo-src-oss     | Yes     | (r ) Yes  | Yes     |   99  
   | yast2  | http://download.opensuse.org/tumbleweed/repo/src-oss          |
7 | repo-update      | repo-update      | Yes     | (r ) Yes  | Yes     |   99  
   | rpm-md | http://download.opensuse.org/update/tumbleweed/               |
[richard@andromeda-ascendant ~]$ sudo zypper dup
Warning: You are about to do a distribution upgrade with all enabled 
repositories. Make sure these repositories are compatible before you continue. 
See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
5 Problems:
Problem: nothing provides libavcodec56(unrestricted) needed by 
vlc-codecs-2.2.4-13.1.i586
Problem: nothing provides kernel-uname-r = 4.7.6-1-default needed by 
broadcom-wl-kmp-default-6.30.223.248_k4.7.6_1-10.2.i586
Problem: nothing provides kernel-uname-r = 4.7.6-1-default needed by 
broadcom-wl-kmp-default-6.30.223.248_k4.7.6_1-10.2.i586
Problem: nothing provides kernel-uname-r = 4.7.6-1-default needed by 
broadcom-wl-kmp-default-6.30.223.248_k4.7.6_1-10.2.i586
Problem: nothing provides kernel-uname-r = 4.7.6-1-default needed by 
broadcom-wl-kmp-default-6.30.223.248_k4.7.6_1-10.2.i586

Problem: nothing provides libavcodec56(unrestricted) needed by 
vlc-codecs-2.2.4-13.1.i586
 Solution 1: keep obsolete vlc-codecs-2.2.4-12.3.x86_64
 Solution 2: break vlc-codecs-2.2.4-13.1.i586 by ignoring some of its 
dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 
c




I have uninstalled the broadcom drivers as I don't have any broadcom hardware, but I am still getting the vlc-codecs error.

[richard@andromeda-ascendant ~]$ zypper se --details vlc-codecs
Loading repository data...
Reading installed packages...

S | Name                 | Type    | Version    | Arch   | Repository
--+----------------------+---------+------------+--------+------------------
i | vlc-codecs           | package | 2.2.4-12.3 | x86_64 | (System Packages)
v | vlc-codecs           | package | 2.2.4-13.1 | x86_64 | packman
v | vlc-codecs           | package | 2.2.4-13.1 | i586   | packman
  | vlc-codecs-debuginfo | package | 2.2.4-13.1 | x86_64 | packman
  | vlc-codecs-debuginfo | package | 2.2.4-13.1 | i586   | packman

As far as I can tell, it should install 2.2.4-13.1 x86_64 from packman.

If you need more information, please let me know.

Kind regards

Richard.

_______________________________________________
Packman mailing list
Packman@links2linux.de
http://lists.links2linux.de/cgi-bin/mailman/listinfo/packman

Antwort per Email an