Hi enrike,
I don't see any reason to run an obsolete pd v 0.43.4-1 under Ubuntu 16.04 because there are fine pd v 0.46.7 extensions in the repos. I think, with a little path configuration and perhaps adding some missing libs you will get most of your old patches running. From 15.10 to 16.04 the libgsl-stuff has been upgraded and is no longer downward compatible. But if you absolutely urge a running pd v 0.43 you will have to recompile: manually edit the build depency from "libgsl0-dev" to "libgsl-dev" and in the debian control files "libgsl0ldbl" to "libgsl2".
Without warranty, other important libs might have been upgraded too.
I myself prefer Ivica Ico Bukvic's pd-l2ork for it's clarity (I think its based on 0.43) and I had to proceed in the manner described above to get a installable .deb for Ubuntustudio 16.04. The pd-l2ork-team inofficially announced to upgrade soon.
best regards
Gerhard

Am 14.05.2016 um 16:11 schrieb enrike:
Hi

I am trying to install the pd-extended_0.43.4-1~raring_amd64.deb package of pd-extended in Ubuntu 16.04 but I get this dependency error

It says it depends on libgsl0ldbl (>= 1.9), and that it is not installed. I did $ aptitude search libgsl0

this returns me

v   libgsl0-dbg
v   libgsl0-dbg:i386
v   libgsl0-dev
v   libgsl0-dev:i386

then I try to sudo aptitude install libgsl0-dev but it just does not install anything at all. I searched with synaptic but that package is not listed there.

I am kind of lost here. any ideas?

enrike

_______________________________________________
Pd-list@lists.iem.at mailing list
UNSUBSCRIBE and account-management -> https://lists.puredata.info/listinfo/pd-list


_______________________________________________
Pd-list@lists.iem.at mailing list
UNSUBSCRIBE and account-management -> 
https://lists.puredata.info/listinfo/pd-list

Reply via email to