Reini Urban wrote:

In lib/Parrot/Configure/Compiler.pm, I agree that 'CONDITIONED_LINE' and
'INVERSE_CONDITIONED_LINE' aren't the clearest names, but '+' and '-' are
far less clear. Change them to something meaningful like 'SHOW_LINE_IF' and
'HIDE_LINE_IF'. We can note the change in DEPRECATED.pod now, and remove
'CONDITIONED_LINE' and 'INVERSE_CONDITIONED_LINE' after a standard
deprecation cycle (one release).

#+ and #- are well known common lisp idioms (the most well-known
reader-macros),
thats why the reverse polish notation in the logic is used. It's just
so much easier
to parse and understand.

Parrot is not lisp. We can do better.

Also in lib/Parrot/Configure/Compiler.pm, change the Polish notation of
"(and a b (not c d))" to a saner "(a and b not (c and d))".

This is ALGOL syntax you suggest is really not "sane" :)

I'm happy to consider other alternatives. As long as they're not Polish notation. :)

In config/gen/makefiles/pge.in, config/gen/makefiles/tge.in, and
config/gen/makefiles/root.in, pick a more meaningful variable name than
'SHRPENV' and a more meaningful condition name than 'cygchkdll'.

SHRPENV is directly from per5,

Parrot is also not Perl 5. We can do better.

and cygchkdll is they only way to check
now for cygwin
without the 57548-CONDITIONED_LINE_enh.patch. After that we can check against
cygwin, the $^O. I really need some #+(and cygwin win32): sections.

As long as it's changed before we merge.

Allison

Reply via email to