On 5/2/07, Larry Wall <[EMAIL PROTECTED]> wrote:
: 2. The question I was trying to answer by poking around: what is/will
: be the P6 equivalent of P5's $. ? I assume the answer is a method on
: the filehandle object, but called what? Should it keep the P5
: IO::Handle name (input_line_number)? Or something else perhaps a
: little less unwieldy (lineno, recno, ...)
Probably something shorter. The problem with "lines" is that they aren't
necessarily lines. But "records" is so 1960s...
Also, anything that names the units could be seen as the count of those units
in the file
as a whole rather that the number read up till now.
Yeah, that's why I suggested the names with "...no". Although that's
not necessarily clear, especially to non-native English speakers.
"...num" might be better...
Tempted to have $io.sofar or some such...
Maybe there could be different (adverbial?) variants of .tell for
different units? Bytes, lines (actual lines irrespective of whatever
the record separator is set to), chunks?
There's a prototype synopsis on variables out in pugs/docs/AES but it's
still pretty rudimentary.
Ah, thanks! Missed that.
As for $. itself as a variable, it's dead.
Yeah, kinda figured.
there are very, very few punctuational variables in Perl 6 compared to Perl 5.
'em are just gone.
And a cheer went up from the multitude... :)
Thanks again for the reply.
Mark J. Reed <[EMAIL PROTECTED]>