> Spec Bag.kxxv
It's a clever name...but maybe too clever?
I find it unfortunate that a method that only returns keys has a 'v'
in its name.
Up to now, we've had a more predictable pattern to naming these accessors.
How about one of:
And what is the use-case for this?
I can see that I might want:
already does that.
I guess you might want to separate out the steps for some reason:
my $selection = median_value_from( $bag.kxxv );
but that would be far more readable/maintainable as:
my $selection = median_value_from( $bag.distribution );