I have seen the same error when renaming the alias.

In /etc/httpd/conf.d/pgadmin4-30.conf

renaming the alias from:

WSGIScriptAlias /pgadmin4-30 /usr/lib/python2.7/site-packages/pgadmin4-30-web/pgAdmin4.wsgi


WSGIScriptAlias /pgadmin4 /usr/lib/python2.7/site-packages/pgadmin4-30-web/pgAdmin4.wsgi

will give the Query Tool Initialization Error

Best and thanks for a nice product


On 17-05-2018 10:13, Murtuza Zabuawala wrote:

Could you provide more details like,

- What is your pgAdmin4 version?
- How did you installed it?
- On which OS you are trying to run pgAdmin4?
- Could you please provide pgAdmin4.log file with debug mode on.
For more information check:https://www.pgadmin.org/faq/#8
(Rename/deleteyour previous log file, once you set the debug mode, try to reproduce the issue in pgAdmin4 again and send us the log file) - If you are running the latest version of pgAdmin4(v3.0) then also provide a screenshot of browser's console window <https://developer.mozilla.org/en-US/docs/Tools/Browser_Console>.

Murtuza Zabuawala
EnterpriseDB: http://www.enterprisedb.com <http://www.enterprisedb.com/>
The Enterprise PostgreSQL Company

On Thu, May 17, 2018 at 2:28 AM, Chris Cowan <chriscowa...@gmail.com <mailto:chriscowa...@gmail.com>> wrote:

    I have encountered a problem with loading the Query Tool with
    Postgres 10 and 9.6.  I have uninstalled/reinstalled and tried
    different versions, but I am unable to clear this problem.  Unless
    there is a known solution I will need to switch to another db.

    Let me know if this is a known problem with a solution.

Reply via email to