> On 30 Apr 2025, at 15:14, David Rowley <dgrowle...@gmail.com> wrote: > On Thu, 1 May 2025 at 00:44, Peter Eisentraut <pe...@eisentraut.org> wrote:
>> I think it's best in general to use str* for strings and mem* for >> not-strings. That's easier to read and also better for static analyzers >> etc. > > The reason I think memcpy is better is that the NUL only needs to be > found once. memcpy() is much faster than strlcpy() because it can > operate on many bytes at once rather than doing 1 byte at a time. I don't disagree, but since similar codepaths in this file use strlcpy now I will opt for that for consistency (and thus readability) with a TODO item to look at changing all these for memcpy during v19. -- Daniel Gustafsson