On 10/15/2016 10:11 AM, Antonio Silva wrote:

I'm using postgres 9.5 on Ubuntu 16.04. I have worked with pg in my
notebook for almost a month but today postgres did not connected. I
tryed both PGAdmin and psql.

Did you do an apt-get upgrade in the interim?

I also tried to login using my own user and postgres but I received the

Server doesn't listen
The server doesn't accept connections: the connection library reports
could not connect to server: Conexão recusada (connection refused) Is
the server running on host "" and accepting TCP/IP connections
on port 5432?

This is indication that Postgres server is not running which is confirmed by your pg_lsclusters output below.

~$ psql database
WARNING: password file "/home/antonio/.pgpass" has group or world
access; permissions should be u=rw (0600) or less
psql: could not connect to server: Arquivo ou diretório não encontrado
(File or directory not found)
    Is the server running locally and accepting
    connections on Unix domain socket "/var/run/postgresql/.s.PGSQL.5432"?

$ pg_lsclusters
Ver Cluster Port Status Owner    Data directory               Log file
9.5 main    5432 down   postgres /var/lib/postgresql/9.5/main

It was the first time I received the warning "password file
"/home/antonio/.pgpass" has group or world access; permissions should be
u=rw (0600) or less" and I fixed it:
-rw-------  1 antonio antonio      137 Set 30 18:50 .pgpass

I had edited postgresql.conf and pg_hba.conf but this morning they were
in their original configuration. So I edited again to:


# - Connection Settings -
listen_addresses = '*'
port = 5432


# Database administrative login by Unix domain socket
local   all             postgres                                md5
# TYPE  DATABASE        USER            ADDRESS                 METHOD
# "local" is for Unix domain socket connections only
local   all             all                                     md5
# IPv4 local connections:
host    all             all   
<>            md5

I also restarted the server (/etc/init.d/postgresql restart) and the

What does  pg_lsclusters show?

How did you try to connect?

I really appreciate any guidance.

All the best,

Antônio Olinto
São Paulo, Brasil

Adrian Klaver

Sent via pgsql-general mailing list (pgsql-general@postgresql.org)
To make changes to your subscription:

Reply via email to