On 10/15/2016 09:09 PM, Antonio Silva wrote:
Dear Adrian and Tom, thanks for your attention.

I did an upgrade on Friday. I use to do this every week.

Log file informed:

2016-10-15 06:15:20 BRT [995-1] FATAL:  data directory
"/var/lib/postgresql/9.5/main" has group or world access
2016-10-15 06:15:20 BRT [995-2] DETAIL:  Permissions should be u=rwx (0700).

The problem with permissions was already indicated to  .pgpass

So I did a "sudo chmod 0700 main" at /var/lib/postgresql/9.5/ directory
and I could connect postgres again!

A cannot understand what happened. How an upgrade changes the
permissions of files an folders? I work with more two desktops with the
same framework (I7, 8 GB, Ubuntu 16.04, PostgreSQL, ...) and it did not

I would look in the the /var/log/apt/history.log.* files that cover Friday and see what upgraded. That may offer a clue.

Well, but I have my database available now. Thanks.

Best regards,

Antônio Olinto

2016-10-15 14:28 GMT-03:00 Adrian Klaver <adrian.kla...@aklaver.com

    On 10/15/2016 10:11 AM, Antonio Silva wrote:


        I'm using postgres 9.5 on Ubuntu 16.04. I have worked with pg in my
        notebook for almost a month but today postgres did not connected. I
        tryed both PGAdmin and psql.

    Did you do an apt-get upgrade in the interim?

        I also tried to login using my own user and postgres but I
        received the

        Server doesn't listen
        The server doesn't accept connections: the connection library
        could not connect to server: Conexão recusada (connection
        refused) Is
        the server running on host "" and accepting TCP/IP
        on port 5432?

Adrian Klaver

Sent via pgsql-general mailing list (pgsql-general@postgresql.org)
To make changes to your subscription:

Reply via email to