At Wed, 22 Mar 2023 10:16:12 +0900, Michael Paquier <[email protected]> wrote in > On Mon, Mar 20, 2023 at 11:57:31AM +0100, Drouvot, Bertrand wrote: > > "Buffer" sounds more appropriate to me, so the attached has been done that > > way. > > This choice is OK for me. > > > + <indexterm> > > + <primary>pg_stat_get_xact_blocks_fetched</primary> > > + </indexterm> > > + <function>pg_stat_get_xact_blocks_fetched</function> ( > > <type>oid</type> ) > > + <returnvalue>bigint</returnvalue> > > + </para> > > + <para> > > + Returns the number of buffer fetches for table or index, in the > > current transaction > > This should be "number of buffer fetched", no?
In the original description, "buffer fetches" appears to be a plural form of a compound noun and correct, similar to "buffer hits" mentioned later. If we reword it, I think it should be "number of buffers fetched". > > + </indexterm> > > + <function>pg_stat_get_xact_blocks_hit</function> ( > > <type>oid</type> ) > > + <returnvalue>bigint</returnvalue> > > + </para> > > + <para> > > + Returns the number of buffer hits for table or index, in the > > current transaction > > + </para></entry> > > This one looks OK to me too. regards. -- Kyotaro Horiguchi NTT Open Source Software Center
