Hi,
On 3/22/23 7:44 AM, Drouvot, Bertrand wrote:
Hi,
On 3/22/23 5:45 AM, Michael Paquier wrote:
On Wed, Mar 22, 2023 at 11:37:03AM +0900, Kyotaro Horiguchi wrote:
In the original description, "buffer fetches" appears to be a plural
form of a compound noun and correct, similar to "buffer hits"
mentioned later. If we reword it, I think it should be "number of
buffers fetched".
Using the plural makes sense, yes.
Yeah, "buffer fetches" is similar to "buffer hits".
For consistency, ISTM than renaming it to "buffers fetched" would also mean
renaming "buffer hits" to "buffers hit". But then it would not be consistent
with the documentation for things like pg_statio_all_tables.heap_blks_hit,
idx_blks_hit, toast_blks_hit,
tidx_blks_hit, pg_statio_all_indexes.idx_blks_hit,
pg_statio_all_sequences.blks_hit
where "Number of buffer hits" is used).
That said, please find enclosed V2 with "buffers fetched" suggested above (and
no changes to
"buffer hits" to keep consistency with the other part of the documentation
mentioned up-thread).
Regards,
--
Bertrand Drouvot
PostgreSQL Contributors Team
RDS Open Source Databases
Amazon Web Services: https://aws.amazon.com
diff --git a/doc/src/sgml/monitoring.sgml b/doc/src/sgml/monitoring.sgml
index 6249bb50d0..c917fbbba7 100644
--- a/doc/src/sgml/monitoring.sgml
+++ b/doc/src/sgml/monitoring.sgml
@@ -5697,6 +5697,32 @@ SELECT pid, wait_event_type, wait_event FROM
pg_stat_activity WHERE wait_event i
</para></entry>
</row>
+ <row>
+ <entry role="func_table_entry"><para role="func_signature">
+ <indexterm>
+ <primary>pg_stat_get_xact_blocks_fetched</primary>
+ </indexterm>
+ <function>pg_stat_get_xact_blocks_fetched</function> (
<type>oid</type> )
+ <returnvalue>bigint</returnvalue>
+ </para>
+ <para>
+ Returns the number of buffers fetched for table or index, in the
current transaction
+ </para></entry>
+ </row>
+
+ <row>
+ <entry role="func_table_entry"><para role="func_signature">
+ <indexterm>
+ <primary>pg_stat_get_xact_blocks_hit</primary>
+ </indexterm>
+ <function>pg_stat_get_xact_blocks_hit</function> ( <type>oid</type> )
+ <returnvalue>bigint</returnvalue>
+ </para>
+ <para>
+ Returns the number of buffer hits for table or index, in the current
transaction
+ </para></entry>
+ </row>
+
<row>
<entry role="func_table_entry"><para role="func_signature">
<indexterm>