On Fri, Mar 24, 2023 at 3:11 AM Euler Taveira <eu...@eulerto.com> wrote: > > If you are adding separate functions as suggested, you should add a comment at > the top of ReplicationSlotAcquire() and ReplicationSlotRelease() functions > saying that LogReplicationSlotAquired() and LogReplicationSlotReleased() > functions should be called respectively after it.
Done. > My suggestion is that the functions should have the same name with a "Log" > prefix. On of them has a typo "Aquired" in its name. Hence, > LogReplicationSlotAcquire() and LogReplicationSlotRelease() as names. It is > easier to find if someone is grepping by the origin function. Done. > I prefer a sentence that includes a verb. > > physical replication slot \"%s\" is acquired > logical replication slot \"%s\" is released Hm, changed for now. But I'll leave it to the committer's discretion. > Isn't the PID important for this use case? If so, of course, you can rely on > log_line_prefix (%p) but if the PID is crucial for an investigation then it > should also be included in the message. On Fri, Mar 24, 2023 at 3:10 AM Peter Smith <smithpb2...@gmail.com> wrote: > > Patch v8 applied OK, and builds/renders the HTML docs OK, and passes > the regression and subscription TAP tests OK. > > Here are some minor comments: > > 1. > + ereport(log_replication_commands ? LOG : DEBUG3, > + (errmsg("acquired physical replication slot \"%s\"", > + slotname))); > > AFAIK those extra parentheses wrapping the "errmsg" part are not necessary. Done > 2. > extern void LogReplicationSlotAquired(bool is_physical, char *slotname); > extern void LogReplicationSlotReleased(bool is_physical, char *slotname); > > The "char *slotname" params of those helper functions should probably > be declared and defined as "const char *slotname". Done. > Otherwise, from a code review perspective the patch v8 LGTM. Thanks. Please have a look at the v9 patch. -- Bharath Rupireddy PostgreSQL Contributors Team RDS Open Source Databases Amazon Web Services: https://aws.amazon.com
v9-0001-Add-LOG-messages-when-replication-slots-become-ac.patch
Description: Binary data