> On 9 Jul 2026, at 09:15, Kyotaro Horiguchi <[email protected]> wrote:
> The changes look functionally correct to me. Agreed. > 1. In BuildRelationList(), if relations without storage should be > excluded regardless of whether they are temporary or non-temporary, I > would personally prefer moving the RELKIND_HAS_STORAGE() check before > the persistence check. That would make the intent a bit clearer. Makes sense, though I am fine with either approach. > 2. In ProcessAllDatabases(), I find it slightly easier to read if the > dropped-database case is handled explicitly first, perhaps by > continuing early, so that DATACHECKSUMSWORKER_SUCCESSFUL remains the > default result for the normal path. I'm not completely sure whether > that check should go just before or just after > pgstat_progress_update_param(), though. I like this suggestion, though I think it should go after the call to pgstat_progress_update_param since the db in question reached ProcessDatabase. I would add it as an else-if case to the conditional testing we have for _FAILED and _ABORTED. -- Daniel Gustafsson
