On Mon, Aug 17, 2026 at 11:06:17AM +0800, Tender Wang wrote:
> Given that the rest of the patch is moving allocation-size arithmetic to
> `Size` and `add_size()`/`mul_size()`, I wonder if this should use
> `add_size()` as well.
> 
> Perhaps the existing size limits make an overflow there unreachable in
> practice, but using `add_size()` would seem more consistent with the rest
> of this patch.

I was wondering about this part as well, but discarded it as not
reachable in practice.  So it should not matter at the end.

The nested calls in hstore_out() feel a bit inelegant as well written
this way.  Something in sequential form would feel much easier to
parse, with one line for each add_size involved.
--
Michael

Attachment: signature.asc
Description: PGP signature

Reply via email to