Hi all, While reviewing a patch for the WAIT FOR command I noticed that its command tag is "WAIT" rather than "WAIT FOR". I could not find this discussed in the main thread, although I have not read all of them, so I might miss something. I want to confirm it because a command tag is not something we can revisit later when we release v19.0.
There are some command tags that are shorter than the command they name: RELEASE, ROLLBACK, SET and WAIT. While the first three commands make sense as they have some variants or some keywords are omittable such as RELEASE [SAVEPOINT], ROLLBACK [TRANSACTION], ROLLBACK TO [SAVEPOINT], SET ROLE, and SET TRANSACTION, the WAIT FOR has a single spelling, "WAIT FOR LSN ...". Strictly the same rule would argue for "WAIT FOR LSN", but "WAIT FOR" is the name the manual gives the command, and it leaves room if other things become waitable in the future. If it was a deliberate choice I am happy to leave it alone. Otherwise I would slightly prefer "WAIT FOR", and I can post the one-line patch. Regards, -- Masahiko Sawada Amazon Web Services: https://aws.amazon.com
