Masahiko Sawada <[email protected]> writes:
> While reviewing a patch for the WAIT FOR command I noticed that its
> command tag is "WAIT" rather than "WAIT FOR". I could not find this
> discussed in the main thread, although I have not read all of them, so
> I might miss something. I want to confirm it because a command tag is
> not something we can revisit later when we release v19.0.
I think it's fine. The FOR is a noise word that's useful only to
make the command's grammar vaguely resemble English. For precedent,
consider INSERT, which must have INTO but that's not part of the
command tag.
> Strictly the same rule would argue for
> "WAIT FOR LSN", but "WAIT FOR" is the name the manual gives the
> command, and it leaves room if other things become waitable in the
> future.
If anything, I'd change the manual. "WAIT FOR" is neither short
nor a useful description of what's being waited for. Either "WAIT"
or "WAIT FOR LSN" would be more plausible as a page heading.
regards, tom lane