Guillaume Smet wrote:
I want to try new pg_dump to connect to old server, but i can't - old
postgres doesn't listening to network socket. Why postgres 6.5.3 not
binding to network socket? It started with this line:
Do you have something like tcpip_socket in your postgresql.conf (I
don't know if it was in 6.5)? If so, you have to set it to true to
make PostgreSQL listen on the network.

i didn't find anything like postgresql.conf on old server. Right now i'm tried to start 6.5.3 on windows (downloaded binary from ftp archive on, installed last cygwin) with the data dir from old server, but there's errors:

D:\pgsql\bin>d:\pgsql\bin\postgres -p 5432 -D d:\\pgsql\\data
6 [main] postgres 2820 _cygtls::handle_exceptions: Exception: STATUS_ACCESS_VIOLATION 426 [main] postgres 2820 open_stackdumpfile: Dumping stack trace to postgres.exe.stackdump 27692 [main] postgres 2820 _cygtls::handle_exceptions: Exception: STATUS_ACCESS_VIOLATION 28338 [main] postgres 2820 _cygtls::handle_exceptions: Error while dumping state (probably corrupted stack)


Exception: STATUS_ACCESS_VIOLATION at eip=0044EBE3
eax=00000000 ebx=00506A90 ecx=00000000 edx=00000001 esi=00506AD1 edi=004E83FC ebp=02862BBC esp=02862BA8 program=d:\pgsql\bin\postgres.exe, pid 2820, thread main
cs=001B ds=0023 es=0023 fs=003B gs=0000 ss=0023
Stack trace:
Frame     Function  Args
02862BBC  0044EBE3  (00000045, 02862BF8, 00000000, 00000000)
02868BF8  004E5A93  (00000001, 004E83C8, 00000000, 0286CC80)
02868C0C  004E8460  (04870150, 0286CCF8, 0044F5A4, 00000000)
0286CC80  004B3518  (00000005, 04870150, 00000005, 04870150)
0286CCB4  0044F698  (00000005, 04870150, 04870090, 60030000)
0286CDA4  610060D8  (00000000, 0286CDDC, 61005450, 0286CDDC)
61005450  61004416  (0000009C, A02404C7, E8611021, FFFFFF48)
27692 [main] postgres 2820 _cygtls::handle_exceptions: Exception: STATUS_ACCESS_VIOLATION 28338 [main] postgres 2820 _cygtls::handle_exceptions: Error while dumping state (probably corrupted stack)

Also tried to compile 6.5.3 from source on newer freebsd - configure doesn't do Makefiles, errors are:

creating GNUmakefile
sed: 35: conftest.s1: unescaped newline inside substitute pattern

and for all Makefiles this message, and Makefiles are empty, so i can't compile it.


As for the upgrade path, I'll go with:
- dump with 7.3 pg_dump, insert your dump into a 7.3 db and run
adddepends contrib shipped with 7.3 on your db (it should fix the
foreign key problem reported by Zdenek);
- then dump your 7.3 db with 8.3 pg_dump and insert your dump into
your 8.3 server.

Ok, that's understood, thanks (thank you too, Zdenek).
But how can i connect with newer pg_dump to this old server, if it's doesn't make a socket to connect to?

С уважением
Александр Лунев

Sent via pgsql-hackers mailing list (
To make changes to your subscription:

Reply via email to