The wCTE patch refers to the feature it's adding as "DML WITH".  I'm
still pretty unhappy with that terminology.  In my view of the world,
"DML" includes SELECT as well as INSERT/UPDATE/DELETE.  The wikipedia
entry about the term
agrees that that's at least the majority usage, and even our own docs
seem to use it to include SELECT as often as not.  Since the distinction
is absolutely critical to talking about this feature sensibly, I don't
think it's a good plan to use an acronym that is guaranteed to produce
uncertainty in the reader's mind.

The best idea I have at the moment is to spell out "data modifying
command" (or "statement") rather than relying on the acronym.
In the code, we could change hasDmlWith to hasModifyingWith, for
example.  The error messages could read like
        data-modifying statement in WITH is not allowed in a view


                        regards, tom lane

Sent via pgsql-hackers mailing list (
To make changes to your subscription:

Reply via email to