On Mon, 2013-12-09 at 12:17 -0500, Robert Haas wrote:
> On Sat, Dec 7, 2013 at 3:12 AM, Jeff Davis <pg...@j-davis.com> wrote:
> > So if we do it this way, then we should pick a new name, like "package".
> That was my first reaction as well, when I looked at this a few years
> ago, but I've since backed away from that position.  You're certainly
> correct that it's awkward to have a single kind of object that behaves
> in two radically different ways, but it's also pretty awkward to have
> the same "stuff" installed as one of two completely different types of
> objects depending on who installed it and how.

I think awkwardness is most visible in the resulting documentation and
error messages.

At the moment, I'm having a difficult time imagining how we explain how
this works to users (or, when they make a mistake or don't get the
results they expect, explain to them what they did wrong and how to fix

        Jeff Davis

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to