On Tue, Dec 24, 2013 at 7:31 PM, Michael Paquier
<michael.paqu...@gmail.com> wrote:
>>> Yep, finding all the code paths with a single keyword is usually a
>>> good thing. Attached is a purely-aesthetical patch that updates the
>>> internal variable name to wal_log_hints.
>> There are many GUC parameters other than wal_log_hints, that their
>> names are not the same as the names of their variables. We should
>> update also them?
> IMO, this looks hard to accept as some existing extensions would break
> (even if fix would be trivial) and it would make back-patching more
> difficult. wal_log_hints is a new parameter though...

That's pretty much how I feel about it as well.  It probably wouldn't
hurt very much to go and rename things like Log_disconnections to
log_disconnections, but changing NBuffers to shared_buffers would
doubtless annoy a lot of people.  Rather than argue about it, I
suppose we might as well leave the old ones alone.

But keeping the names consistent for new parameters seems simple
enough, so I've committed your patch.

Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to