On Fri, Feb 7, 2014 at 5:06 AM, Andres Freund <and...@2ndquadrant.com> wrote: > On 2014-02-04 12:02:45 -0500, Tom Lane wrote: >> Andres Freund <and...@2ndquadrant.com> writes: >> > On 2014-02-04 11:36:22 -0500, Tom Lane wrote: >> >> -1. This is not a general solution to the problem. There are other >> >> GUCs for which people might want spaces in the value. >> >> > Sure, I didn't say it was. But I don't see any oother values that are >> > likely being passed via PGOPTIONS that frequently contain spaces. >> >> application_name --- weren't we just reading about people passing entire >> command lines there? (They must be using some other way of setting it >> currently, but PGOPTIONS doesn't seem like an implausible source.) > > You can't easily use PGOPTIONS to set application_name in many cases > anyway, libpq's support for it gets in the way since it takes effect > later. And I think libpq is much more likely way to set it. Also you can > simply circumvent the problem by using a different naming convention, > that's not problem with repeatable read. > > So I still think we should add read_committed, repeatable_read as aliases.
Like Tom, I'm -1 on this. This is fixing the problem from the wrong end. But introducing an escaping convention seems more than prudent. -- Robert Haas EnterpriseDB: http://www.enterprisedb.com The Enterprise PostgreSQL Company -- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers