On 23.4.2014 16:07, Tom Lane wrote:
> To be concrete: let's add a new boolean parameter with the semantics
> of "final function takes extra dummy arguments" (default false).
> There would need to be one for the separate moving-aggregate final
> function too, of course.
> The best naming idea I've got right now is "finalfunc_extra" and
> "mfinalfunc_extra", but maybe somebody can do better?
Do we really need a separate parameter for this? Couldn't this be
decided simply using the signature of the final function? Either it has
a single parameter (current behavior), or it has the same parameters as
the state transition function (new behavior).
Sent via pgsql-hackers mailing list (firstname.lastname@example.org)
To make changes to your subscription: