On 13.5.2014 20:27, Tomas Vondra wrote:
> Hi all,
> 
> a few days ago I switched magpie into an LXC container, and while
> fixinig unrelated issue there, I noticed that although the tests seemed
> to run, some of the results are actually rubbish because of missing locales.

I forgot to mention that I noticed another (possible) issue - ISTM the
buildfarm client is not packing all the log files. For for the failure
in REL9_3_STABLE, there are 32 log files packed:


http://www.pgbuildfarm.org/cgi-bin/show_log.pl?nm=magpie&dt=2014-05-13%2014%3A59%3A46

However in the lastrun-logs I see 81 files, and upon closer inspection
it seems that pretty much logs for all custom locales (cs_CZ.*, sk_SK.*)
are missing:

    initdb-cs_CZ.ISO-8859-2
    initdb-cs_CZ.UTF-8
    initdb-cs_CZ.WIN-1250
    initdb-sk_SK.ISO-8859-2
    initdb-sk_SK.UTF-8
    install-check-cs_CZ.ISO-8859-2
    install-check-cs_CZ.UTF-8
    install-check-cs_CZ.WIN-1250
    install-check-sk_SK.ISO-8859-2
    install-check-sk_SK.UTF-8
    pl-install-check-cs_CZ.ISO-8859-2
    pl-install-check-cs_CZ.UTF-8
    pl-install-check-cs_CZ.WIN-1250
    pl-install-check-sk_SK.ISO-8859-2
    pl-install-check-sk_SK.UTF-8
    startdb-cs_CZ.ISO-8859-2-1
    startdb-cs_CZ.ISO-8859-2-2
    startdb-cs_CZ.ISO-8859-2-3
    startdb-cs_CZ.UTF-8-1
    startdb-cs_CZ.UTF-8-2
    startdb-cs_CZ.UTF-8-3
    startdb-cs_CZ.WIN-1250-1
    startdb-cs_CZ.WIN-1250-2
    startdb-sk_SK.ISO-8859-2-1
    startdb-sk_SK.ISO-8859-2-2
    startdb-sk_SK.ISO-8859-2-3
    startdb-sk_SK.UTF-8-1
    startdb-sk_SK.UTF-8-2
    startdb-sk_SK.UTF-8-3
    stopdb-cs_CZ.ISO-8859-2-1
    stopdb-cs_CZ.ISO-8859-2-2
    stopdb-cs_CZ.ISO-8859-2-3
    stopdb-cs_CZ.UTF-8-1
    stopdb-cs_CZ.UTF-8-2
    stopdb-cs_CZ.UTF-8-3
    stopdb-cs_CZ.WIN-1250-1
    stopdb-sk_SK.ISO-8859-2-1
    stopdb-sk_SK.ISO-8859-2-2
    stopdb-sk_SK.ISO-8859-2-3
    stopdb-sk_SK.UTF-8-1
    stopdb-sk_SK.UTF-8-2
    stopdb-sk_SK.UTF-8-3

A few days back this was reported properly
(http://www.pgbuildfarm.org/cgi-bin/show_log.pl?nm=magpie&dt=2014-04-17%2000%3A07%3A36).
I doubt this is related to the LXC container, but I was running 4.9
version of the buildfarm client back then, while now it's running in
4.12. I'd guess this is the actual cause.

regards
Tomas


-- 
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers

Reply via email to