2014-09-12 3:44 GMT+02:00 Peter Eisentraut <pete...@gmx.net>:

> On 9/4/14 4:23 PM, Pavel Stehule wrote:
> > It is little bit hard to read.
>
> > maybe better be more verbose - and it can be in alone function, because
> > it is "analyze only"
> >
> > if (stage == -1)
> > {
> >   for (i = 0; i < 3; i++)
> >   {
> >         puts(gettext(stage_messages[i]));
> >         executeCommand(conn, stage_commands[i], progname, echo);
> >         run_vacuum_command(conn, sql.data, echo, dbname, table,
> progname);
> >   }
> > }
> > else
> > {
> >     puts(gettext(stage_messages[stage]));
> >     executeCommand(conn, stage_commands[stage], progname, echo);
> >     run_vacuum_command(conn, sql.data, echo, dbname, table, progname);
> > }
>
> Done that way, thanks!
>

Thank you

It is interesting feature

Pavel

Reply via email to