On 2014-09-23 10:31:24 -0400, Robert Haas wrote:
> I suggest we count these things:
> 1. The number of buffers the reclaimer has put back on the free list.
> 2. The number of times a backend has run the clocksweep.
> 3. The number of buffers past which the reclaimer has advanced the clock
> sweep (i.e. the number of buffers it had to examine in order to reclaim the
> number counted by #1).
> 4. The number of buffers past which a backend has advanced the clocksweep
> (i.e. the number of buffers it had to examine in order to allocate the
> number of buffers count by #3).
> 5. The number of buffers allocated from the freelist which the backend did
> not use because they'd been touched (what you're calling
> It's hard to come up with good names for all of these things that are
> consistent with the somewhat wonky existing names. Here's an attempt:
> 1. bgreclaim_freelist
> 2. buffers_alloc_clocksweep (you've got buffers_backend_clocksweep, but I
> think we want to make it more parallel with buffers_alloc, which is the
> number of buffers allocated, not buffers_backend, the number of buffers
> *written* by a backend)
> 3. clocksweep_bgreclaim
> 4. clocksweep_backend
I think bgreclaim/backend should always be either be a prefix or a
postfix. But not one in some variables and some in another.
> 5. freelist_touched
I wonder if we shouldn't move all this to a new view, instead of
stuffing it somewhere where it really doesn't belong. pg_stat_buffers or
something like it.
Andres Freund http://www.2ndQuadrant.com/
PostgreSQL Development, 24x7 Support, Training & Services
Sent via pgsql-hackers mailing list (email@example.com)
To make changes to your subscription: