On 2014-10-04 14:25:27 +0900, Michael Paquier wrote: > On Sat, Oct 4, 2014 at 9:24 AM, Michael Paquier <michael.paqu...@gmail.com> > wrote: > > > > > > > On Sat, Oct 4, 2014 at 6:48 AM, Andres Freund <and...@2ndquadrant.com> > > wrote: > > > >> On 2014-10-03 14:02:08 -0400, Robert Haas wrote: > >> > On Fri, Oct 3, 2014 at 7:57 AM, Andres Freund <and...@2ndquadrant.com> > >> wrote: > >> > > I do wonder whether --create/--drop aren't somewhat wierd for > >> > > pg_receivexlog. It's not that clear what it means. It'd be ugly, but > >> we > >> > > could rename them --create-slot/drop-slot. > >> > > >> > +1 on doing it, -1 on it being ugly. > >> > >> The reason I'm calling it uglyu is that it's different from > >> pg_recvlogical. We could change it there, too? A bit late, but probably > >> better than having a discrepancy forever > >> > > I'm on board to make things as consistent as possible between both > > utilities, the only reason why --create/--drop are used in my patch is for > > the sake of consistency btw. 9.4 ship has not sailed yet, and IMO it is > > important from the user prospective if options are a maximum consistent > > between pg_receivexlog and pg_recvlogical. That would be even better if > > change is done before 9.4beta3 shows up, and I doubt that there are many > > users using the --create/--drop options already. > > > And as I am on it, attached is a patch that can be applied to master and > REL9_4_STABLE to rename the --create and --drop to --create-slot and > --drop-slot.
Misses logicaldecoding.sgml... I'll fix that up, once there's agreement whether we should continue accept the old form. No need to send a new version. Greetings, Andres Freund -- Andres Freund http://www.2ndQuadrant.com/ PostgreSQL Development, 24x7 Support, Training & Services -- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers