It looks like the docs are indeed wrong.

According to http://sourceforge.net/p/mingw-w64/wiki2/TypeTriplets/ it should be x86_64-w64-mingw32


So in summary, the docs at
http://www.postgresql.org/docs/current/static/installation-platform-notes.html#INSTALLATION-NOTES-MINGW
should be updated from:

    --host=x86_64-w64-mingw

to:

    --host=x86_64-w64-mingw32

Not sure where to report that?


On 1/18/2016 12:52 PM, Igal @ Lucee.org wrote:
Per the docs at
http://www.postgresql.org/docs/current/static/installation-platform-notes.html#INSTALLATION-NOTES-MINGW

"To build 64 bit binaries using MinGW ... and run configure with the --host=x86_64-w64-mingw option"

But when I try to run: $ ~/sources/postgresql-9.5.0/configure --host=x86_64-w64-mingw

I get an error system mingw not recognized:

checking build system type... x86_64-pc-mingw64
checking host system type... Invalid configuration `x86_64-w64-mingw': *system `mingw' not recognized* configure: error: /bin/sh /home/Admin/sources/postgresql-9.5.0/config/config.sub x86_64-w64-mingw failed

The sources were downloaded from http://www.postgresql.org/ftp/source/v9.5.0/

Are the docs up to date?

Thanks

--

Igal Sapir
Lucee Core Developer
Lucee.org <http://lucee.org/>


Reply via email to