On 05.02.2016 um 18:40 Jason Petersen wrote:
On Feb 3, 2016, at 2:38 AM, Peter Moser <pitiz...@gmail.com> wrote:

Does anyone had similar problems? Do I have to configure Eclipse to understand 
the PG_RMGR macro or is there another possibility to teach Eclipse these macros?


I just built 9.6 under Eclipse CDT to try this out and was able to open e.g. 
heapam.c without any error markers.

I added PostgreSQL as a “Makefile Project with Existing Code” after running 
./configure from the command-line. After that, I built the project from within 
Eclipse by adding the ‘all’ make target and running it.

I imported PG the same way, configured from terminal with

        export CFLAGS="-g0"
        ./configure \
                --prefix="/home/p/pg/build" \
                --enable-debug \
                --enable-depend \

I built the project from command-line, not from within Eclipse. First I thought that this may have caused all this problems, but no...

One setting I usually change: right-click the project, pick Properties, then drill 
down through C/C++ General -> Preprocessor Include Paths. In the Provider pane, 
there is an entry for “CDT GCC Build Output Parser”. I’m not sure if this is 
strictly necessary, but I set my “Container to keep discovered entries” setting to 

Basically, Eclipse scans the make output for -I flags, then notes all the 
includes used to build each file, so the static analyzer, etc. can have more 
accurate information (it is crucial that the “Compiler command pattern” in this 
window be a regex that will match the compiler binary you use, so if you have 
/usr/local/bin/gcc, and “gcc” is the pattern, you are in for trouble).

After running the build, Eclipse should now know what includes are used for each file 
and stop whining. If it ever seems to have problems, you can kick it by running a 
clean target, then all, then picking “Project -> C/C++ Index -> Rebuild” (I 

Thanks for all your suggestions, tried all of them, but it made no difference. What finally solved my problems was to delete the BUILD and cluster DATA folders that I had created, re-configured the system. Deleted the project in Eclipse, and imported it again after configure. All wrong markers disappeared. Maybe the C-file index of Eclipse was corrupted or so. Also rebuilding it didn't work. The only difference from my previous attempt was the CFLAGS thing (see above), but I do not know if this changes anything related to markers.


Jason Petersen
Software Engineer | Citus Data

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to