Josh Kupershmidt <schmi...@gmail.com> writes:
> On Tue, Feb 9, 2016 at 2:16 PM, Filip RembiaÅkowski
> <filip.rembialkow...@gmail.com> wrote:
>> But then it becomes disputable if SQL syntax change makes sense.
>> ---we had this,
>> NOTIFY channel [ , payload ]
>> ---and in this patch we have this
>> NOTIFY [ ALL | DISTINCT ] channel [ , payload ]
>> --- but maybe we should have this?
>> NOTIFY channel [ , payload [ , mode ] ]
> What about adopting the options-inside-parentheses format, the way
> EXPLAIN does nowadays, something like:
> NOTIFY (DEDUPLICATE FALSE, MODE IMMEDIATE) mychannel;
FWIW, I think it would be a good thing if the NOTIFY statement syntax were
not remarkably different from the syntax used in the pg_notify() function
call. To do otherwise would certainly be confusing. So on the whole
I'd go with the "NOTIFY channel [ , payload [ , mode ] ]" option.
regards, tom lane
Sent via pgsql-hackers mailing list (email@example.com)
To make changes to your subscription: