Anastasia Lubennikova <a.lubennik...@postgrespro.ru> writes: > 15.03.2016 22:28, David Steele: >> I'm not in favor of the "4", either. I think I would prefer >> JULIAN_MAXYEAR_STAMP.
> This point is related to another patch > https://commitfest.postgresql.org/9/540/. > And added to this patch just for compatibility. > If Tom wouldn't change the name of the macros there, I don't see any > reasons why should we do it in this patch. Yeah, I didn't like the "4STAMPS" terminology at all. It ended up being moot for that patch, because the answer eventually turned out to be that we needed to decouple the Julian-date boundaries from the datatype boundaries altogether. But I would've renamed those macros to something else if they'd stayed. regards, tom lane -- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers