* Noah Misch (n...@leadboat.com) wrote: > On Fri, Apr 01, 2016 at 11:07:01PM -0400, Tom Lane wrote: > > Stephen Frost <sfr...@snowman.net> writes: > > > * Noah Misch (n...@leadboat.com) wrote: > > >> I see some advantages of writing "TokenUser", as you propose. However, > > >> our > > >> error style guide says "Avoid mentioning called function names, either; > > >> instead say what the code was trying to do." Mentioning an enumerator > > >> name is > > >> morally similar to mentioning a function name. > > > > > That's a fair point, but it doesn't mean we should use a different > > > spelling for the enumerator name to avoid that piece of the policy. I > > > certianly don't see "token user" as saying "what the code was trying to > > > do" in this case. > > > > FWIW, "token user" conveys entirely inappropriate, politically incorrect > > connotations to me ;-). I don't have any great suggestions on what to use > > instead, but I share Stephen's unhappiness with the wording as-committed. > > The wording in GetTokenUser() and AddUserToTokenDacl() seems fine; let's > standardize on that. Also, every GetTokenUser() failure has been yielding two > messages, the second contributing no further detail. I'll reduce that to the > usual one message per failure.
This approach works for me. Thanks! Stephen
Description: Digital signature