I noticed that commit 7e137f846 added functions named max() and min()
to pgbench's expression syntax.  Unfortunately, these functions have
zilch to do with what max() and min() do in SQL.  They're actually more
like the greatest() and least() server-side functions.


While I can't imagine that we'd ever want to implement true aggregates in pgbench expressions, it still seems like this is a recipe for confusion. Shouldn't we rename these to greatest() and least()?

My 0,02€: I like the simplicity of min/max names and I think that anyone would manage to deal with this level of confusion in a pgbench script, so I would not bother.

But if it is to be changed, best do it now!

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to