On Wed, May 4, 2016 at 5:41 PM, Tom Lane <t...@sss.pgh.pa.us> wrote:
> I noticed that commit 7e137f846 added functions named max() and min()
> to pgbench's expression syntax.  Unfortunately, these functions have
> zilch to do with what max() and min() do in SQL.  They're actually more
> like the greatest() and least() server-side functions.
> While I can't imagine that we'd ever want to implement true aggregates
> in pgbench expressions, it still seems like this is a recipe for
> confusion.  Shouldn't we rename these to greatest() and least()?

Yeah, that's probably a good idea.

Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to