Stephen Frost <> writes:
> * Tom Lane ( wrote:
>> What I think might be worth considering is inserting underscores,
>> eg "pg_receive_wal", anywhere that we are running the abbreviation
>> directly against another word.  We won't get another chance.

> Wouldn't that make it 'pg_recv_wal'?  Or were you referring to the 'wal'
> as being the abbreviation?

The latter.  As far as the programs go, that would be


The other cases you mention are, for the most part, words that we're
running together ("db" is the only exception) so they're not committing
double sins against readability.  Anyway, I'm not suggesting that we
should rename anything this patch isn't touching already.

                        regards, tom lane

PS: I'm trying hard not to open the can of worms labeled "pg_dump_wal".

Sent via pgsql-hackers mailing list (
To make changes to your subscription:

Reply via email to