On Mon, Jan 30, 2017 at 12:50 PM, Ashutosh Bapat
<ashutosh.ba...@enterprisedb.com> wrote:
> On Sat, Jan 28, 2017 at 8:41 PM, Peter Eisentraut
> <peter.eisentr...@2ndquadrant.com> wrote:
>> On 1/26/17 4:49 AM, Masahiko Sawada wrote:
>>> Sorry, I attached wrong version patch of pg_fdw_xact_resovler. Please
>>> use attached patch.
>> So in some other thread we are talking about renaming "xlog", because
>> nobody knows what the "x" means.  In the spirit of that, let's find
>> better names for new functions as well.
> It's common in English (not just the database jargon) to abbreviate
> "trans" by "x" [1]. xlog went a bit far by abbreviating whole
> "transaction" by "x". But here "xact" means "transact", which is fine.
> May be we should use 'X' instead of 'x', I don't know. Said that, I am
> fine with any other name which conveys what the function does.
> [1] https://en.wikipedia.org/wiki/X

"txn" can be used for abbreviation of "Transaction", so for example
I'm also fine to change the module and function name.


Masahiko Sawada
NTT Open Source Software Center

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to