On 01/31/2017 07:52 AM, Amit Langote wrote:
On 2017/01/31 6:57, Tomas Vondra wrote:
On 01/30/2017 09:37 PM, Alvaro Herrera wrote:
Looks good to me. I don't think we need to keep the names very short --
I would propose "standistinct", "stahistogram", "stadependencies".
Yeah, I got annoyed by the short names too.
This however reminds me that perhaps pg_mv_statistic is not the best name.
I know others proposed pg_statistic_ext (and pg_stats_ext), and while I
wasn't a big fan initially, I think it's a better name. People generally
don't know what 'multivariate' means, while 'extended' is better known
(e.g. because Oracle uses it for similar stuff).
So I think I'll switch to that name too.
+1 to pg_statistics_ext. Maybe, even pg_statistics_extended, however
being that verbose may not be warranted.
Yeah, I think pg_statistic_extended / pg_stats_extended seems fine.
Tomas Vondra http://www.2ndQuadrant.com
PostgreSQL Development, 24x7 Support, Remote DBA, Training & Services
Sent via pgsql-hackers mailing list (email@example.com)
To make changes to your subscription: