On Thu, Mar 16, 2017 at 4:15 PM, vinayak <pokale_vinayak...@lab.ntt.co.jp>
> On 2017/03/16 10:34, Haribabu Kommi wrote:
> Updated patch attached.
> The patch looks good to me.
Thanks for the review.
How about rename the view as "pg_stat_walwriter"?
With the use of name "walwriter" instead of "walwrites", the
user may confuse that this view is used for displaying
walwriter processes statistics. But actually it is showing
the WAL writes activity in the instance. Because of this
reason, I went with the name of "walwrites".
> The columns of view :
> backend_writes -> backend_wal_writes
> writes-> background_wal_writes
> write_blocks-> wal_write_blocks
As the view name already contains WAL, I am not sure
whether is it required to include WAL in every column?
I am fine to change if others have the same opinion of
adding WAL to column names.