I'd been thinking that staenabled is not the most suitable column name for storing the types of statistics that are defined for the extended statistics. For me, this indicates that something can be disabled, but there's no syntax for that, and even if there was, if we were to enable/disable the kinds, we'd likely want to keep tabs on which kinds were originally defined, otherwise it's more of an ADD and DROP than an ENABLE/DISABLE.
"stakind" seems like a better name. I'd have personally gone with "statype" but pg_statistic already thinks stakind is better. A patch which changes this is attached -- David Rowley http://www.2ndQuadrant.com/ PostgreSQL Development, 24x7 Support, Training & Services
Description: Binary data
-- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers