On 04/13/2017 03:28 PM, Tom Lane wrote:
Tomas Vondra <tomas.von...@2ndquadrant.com> writes:
On 04/12/2017 03:36 PM, David Rowley wrote:
"stakind" seems like a better name. I'd have personally gone with
"statype" but pg_statistic already thinks stakind is better.
+1 to stakind
I agree with that, but as long as we're rethinking column names here,
was it a good idea to use the same "sta" prefix in pg_statistic_ext
as in pg_statistic? I do not think there's anyplace else where we're
using the same table-identifying prefix in two different catalogs,
and it seems a little pointless to follow that convention at all if
we're not going to make it a unique prefix.
We could go with "ste" perhaps, or break the convention of 3-character
prefixes and go with "stae".
We have a bunch of > 3-character prefixes already: amop*, amproc*,
enum*, cast*. But I think I nevertheless like "ste" better.
That said, we also have two existing tables with the same prefix:
pg_constraint and pg_conversion. Both use "con" as the prefix. Yes, it
is a bit confusing, let's not to make the same mistake again.
Sent via pgsql-hackers mailing list (email@example.com)
To make changes to your subscription: