On 20 April 2017 at 07:29, Euler Taveira <eu...@timbira.com.br> wrote: > 2017-04-19 1:32 GMT-03:00 Michael Paquier <michael.paqu...@gmail.com>: >> >> I vote for "location" -> "lsn". I would expect complains about the >> current inconsistency at some point, and the function names have been >> already changed for this release..
OK, so I've created a draft patch which does this. In summary of what it does 1. Renames all wal_location functions to wal_lsn. 2. Renames all system view columns to use "lsn" instead of "location" 3. Rename function parameters to use "lsn" instead of "location". 4. Rename function parameters "wal_position" to "lsn". (Not mentioned before, but seems consistency was high on the list from earlier comments on the thread) 5. Change documentation to reflect the above changes. 6. Fix bug where docs claimed return type of pg_logical_slot_peek_changes.location was text, when it was pg_lsn (maybe apply separately?) 7. Change some places in the func.sgml where it was referring to the lsn as a "position" rather than "location". (We want consistency here) Is this touching all places which were mentioned by everyone? -- David Rowley http://www.2ndQuadrant.com/ PostgreSQL Development, 24x7 Support, Training & Services
Description: Binary data
-- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers