On Tue, Apr 18, 2017 at 7:58 AM, Magnus Hagander <mag...@hagander.net> wrote: >> Yeah, that would be reasonable. It can't be called just "password", >> though, because there's no way to implement "password-or-md5-or-scram" in a >> sensible way (see my reply to Simon at ). Unless we remove the support >> for what "password" does today altogether, and redefine "password" to mean >> just "md5-or-beyond". Which might not be a bad idea, but that's a separate >> discussion. > > It is an interesting one though. "password" today is really only useful in > the case of db_user_namespace=on, right? Given the very few people I think > are using that feature, it wouldn't be unreasonable to rename it to > something more closely related to that.
I think it would be nice to have something with the same functionality as db_user_namespace that smells less like a giant hack. Does db_user_namespace work with SCRAM? -- Robert Haas EnterpriseDB: http://www.enterprisedb.com The Enterprise PostgreSQL Company -- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers