On Fri, May 19, 2017 at 6:35 PM, Amit Langote
<langote_amit...@lab.ntt.co.jp> wrote:
> On 2017/05/19 15:16, Thomas Munro wrote:
>> Would TransitionCaptureState be a better name for this struct?
> Yes.  Although, losing the Trigger prefix might make it sound a bit
> ambiguous though.  Right above its definition, we have TriggerData.  So,
> maybe TriggerTransitionCaptureState or TriggerTransitionCaptureData or
> TriggerTransitionData may be worth considering.

Ok, here's a version using TransitionCaptureState.  Those other names
seem too long, and "TriggerTransition" is already in use so
"TriggerTransitionData" seems off the table.  Having the word
"capture" in there seems good, since this is an object that controls
what we capture when we process a modify a set of tables.  I hope
that's clear.

Thomas Munro

Attachment: transition-tuples-from-child-tables-v8.patch
Description: Binary data

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to