On Tue, Jun 27, 2017 at 3:44 AM, Tom Lane <t...@sss.pgh.pa.us> wrote: > Looks good as far as it goes, but I wonder whether any of the other > get_slot_xmins calls need polling too. Don't feel a need to add such > calls until someone exhibits a failure there, but I won't be very > surprised if someone does.
I got the same thought, wondering as well if get_slot_xmins should be renamed check_slot_xmins with the is() tests moved inside it as well. Not sure if that's worth the API ugliness though. > Anyway, pushed this patch with minor editing. Thanks! Thanks. -- Michael -- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers